Windows 7 Audio Device Graph Isolation

Posts 1 - 12 of 12
  1. 231758
    zerograv : Sun 29th Aug 2010 : 4 years ago Well having been googling this problem for what seems like days now, I have decided to ask all you great people if you have any suggestions.

    My problem seems to be this:

    A small application (audiodg.exe) which runs in the background in vista or later, located in the system directory, starts slowly, but over time, it HOGS up more and more memory. It is an obvious mem leak related to windows as I have made sure my system is malware free and running all the current drivers. I have recently done an OS reinstall and the problem persists.

    Any suggestions?
  2. 609523
    3rdNippleMusic : Sun 29th Aug 2010 : 4 years ago honestly man, I'm not up to speed on all the new stupid services MS split everything in to, but you may find stuuf at http://support.microsoft.com

    funny, 2 hours b4 I read this I was wishing that you could buy CORE windows and have all the other crap as module add-ons so you could actually use that fast pc...

    good luck man,

    Neal Visher
  3. 444193
    StereoMathematics : Sun 29th Aug 2010 : 4 years ago try going into task manager, go to the process tab, right click the audiodg.exe and open its file location. once you have found the file folder, delete it. if you cant, just end process. if you are unable to delete it, you can prevent it from running at start up:
    click start
    click run
    type in msconfig
    click on the start up tab
    uncheck it to disable it on startup
    restart
    do you know what this exe goes to? if you disable it or delete it, it could prevent something you need from working right.
  4. 444193
    StereoMathematics : Sun 29th Aug 2010 : 4 years ago http://technicallyeasy.net/2009/03/fix-audiodgexe-high-cpu-usage/

    if you already saw this then never mind, but try this too.
  5. 231758
    zerograv : Mon 30th Aug 2010 : 4 years ago You can't disable it because it is the DRM for ALL windows audio. no audiodg.exe, NO sound!

    and i couldn't get that link you gave me to work.
  6. 231758
    zerograv : Mon 30th Aug 2010 : 4 years ago its funny because i have seen so many people link to that adress as the fix to this problem but i can't seem to see the site.
  7. 444193
    StereoMathematics : Tue 31st Aug 2010 : 4 years ago I recently had a problem when playing movies through iTunes on a laptop. At various parts of the movie, the entire laptop would become extremely slow, causing the movie to sputter. This happened at infrequent intervals. The laptop has a dual core 1.6Ghz and 2GB of RAM, so I new it was more than capable of playing a movie.

    To look into the problem, I had the performance monitor running while I played a movie. Once the movie began to slow and sputter, I viewed the performance monitor to see which process was causing the problem. When I viewed the performance monitor I noticed that a process called audiodg.exe was consuming 35-40% of the CPU. I then investigated the problem and found a probable fix to the issue.

    What is Audiodg.exe?

    Audio

    The audiodg.exe file made its appearance in Microsoft Vista, which explains why I haven’t seen this file before. When I viewed the properties of the file, the description stated Windows Audio Device Graph Isolation, which doesn’t help explain what it does.

    After doing a little research I found out that the audiodg.exe file hosts the audio engine for Vista, and from what I hear Windows 7 as well. All the DSP and audio processing is performed within this file. Vendors are able to install their own DSP and audio effects into the audio pipeline, which will then be processed by audiodg.exe.

    Unfortunately, this can also lead to some problems, as I experienced. Some audio effects can consume CPU and memory if not properly coded. How do we fix the problem? Lets take a look.
    Disabling Audio Effects

    In order to fix the high CPU usage, I disabled the audio enhancements processed by the audiodg.exe file. To disable the audio enhancements, use the following steps:

    1. Right-click the speaker icon in the lower right corner.
    2. Select Playback Devices from the menu. A list of devices should appear on the screen.
    3. Double-click the device that has a green checkmark. The properties windows for that device should open.
    4. Click the Enhancements tab at the top.
    5. From the list of enhancements, uncheck all of them, or click the Disable all enhancements checkbox.
    6. Click the OK button to save your changes and close the window.
    7. Click OK to close the Playback Devices window.

    Once I disabled the enhancements, the movie played without any issues. I also didn’t notice any difference in sound with the enhancements disabled. If I do want to use sound enhancements, I’ll stick to the the options provided in the application.
  8. 444193
    StereoMathematics : Tue 31st Aug 2010 : 4 years ago copy pasta from the site
  9. 231758
    zerograv : Tue 31st Aug 2010 : 4 years ago yeah i've read this on other sites but the problem seems to be that i don't use enhancements on my audio. I've been doing some tests with windows media player and DFX audio enhancer to see if i can recreate the problem, but so far no success.
  10. 444193
    StereoMathematics : Wed 1st Sep 2010 : 4 years ago so it only happens every now and then? could be a conflict with other sound drivers. someone usin ac97 said that they had to disable it at boot, and manually activate the service each time windows boots up. they said that it never used up a ridiculous amount of ram or cpu. creative drivers seem to also cause a conflict when running on 64 bit vista systems. thats really all i could find.
    i see more and more issues like this. problems arise, you go to the manufacturers site, and they offer no help to finding a solution. since it only seems to be a vista problem, it could be that no one at microsoft cares enough to fix it, and would rather you just buy windows 7.
    ill keep lookin around, i go back to school tomorrow so ill ask some of the techies their.
  11. 231758
    zerograv : Wed 1st Sep 2010 : 4 years ago Well that's the problem you see, my OS is Windows 7 Ultimate x64. Win 7 uses the same audio architecture as Vista, meaning this problem has persisted for 2 operating systems with basically no known fix aside from disabling enhancements which seems to only work for some. Besides the fact that some people by certain cards FOR the enhancements they come with (games for example)

    I have AC97 disabled in boot, I use a Tascam US-2000 which is compatible with Win 7 x64. It isn't a crippling issue now that I know it is there, I can just just restart the audio service before I record anything (which I would do anyway). My computer has more then enough power to deal with the issue, but as we know with recording its nice to have programs not using more RAM then they should be using. Every once in a while the leak can get upwards of a few gigs, but that is if i'm listening to playback for hours on end without a restart of the service

    Hey and thanks for your help!
  12. 444193
    StereoMathematics : Thu 2nd Sep 2010 : 4 years ago hey no problem, sorry i couldnt give a real solution. lol, i guess im one of the lucky ones that dont have this problem at all, cause i dont even see it on my system, so i cant even try to mess with it. i felt kinda weird asking about a windows problem in a linux class, but the prof pretty much said the same thing, just turn it off and turn it back on. someone did suggest one crazy idea, idk if it applies to you, but some of the big name computer dealers, like hp, dell, sony..., sometimes its their factory hardware that causes issues with user installed hardware.
Posts 1 - 12 of 12

 ! You need to Log In or Register to post here.

From The Forums
Watched Forum Threads
Featured Chill Out Track